Categories

Saturday, January 19, 2019

RIP and version of RIP.

RIP:-

RIP stands for Routing Information Protocol. It’s a distance vector protocol. This protocol based on the Bellman-Ford algorithm. According to the Bellman-Ford algorithm it computes shortest paths for one network to another network. Routing Information Protocol one of the oldest protocol for defines a way of routers. By IETF (Internet Engineering Task Force) the Routing Information Protocol classified as an Interior Gateway Protocol (IGP). 
In every 30 seconds RIP sends the routing table of all active interfaces. By default RIP allows 15 hop count. If a destination is 16, it would be unreachable. RIP easy to configure because it’s doesn’t require any parameters or protocols.  RIP better for small area network because it’s allow maximum 15 hop count. By hop count limitation RIP help to stops routing loops. For controlling routing loop or routing loop solutions RIP uses Split Horizon and Route Poisoning and Hold Down mechanisms. The RIP is not best choice for routing because its scalability and coverage are not better than EIGRP, IS-IS or OSPF

RIP Versions:-

RIPv1:-

RIPv1 was written by the Charles Hedrick and published in 1988 and defined in RFC 1058. RIPv1 uses classful routing. In classful routing the routing updates do not carry subnet mask or subnet information. It means all devices that are available in network must be configuring with same subnet mask or same class. RIPv1 not support for router authentication.

RIPv2:-

RIPv1 came with many shortcomings. For remove RIPv1 shortcomings the RIPv2 launched. RIPv2 developed in 1993 and last standardized in 1998 and defined in RFC 2453. RIPv2 comes with classless routing. In classless routing the routing updates carry subnet mask or subnet information. In RIPv2 the route tags were added, they allow distinction between routes learned from RIP protocol and routes learned from other protocols.

How to configure RIP:-

I am configuring a simple lab with RIPv1, which is easy for beginners to understand. 
I have taken three routers and three computers and set the router name R1, R2 and R3. After that i set up ip address for all router interfaces. Now I configure RIP.


Configure RIP R1 Router:-

R1(config)#router rip
R1(config)#network 20.0.0.0
R1(config)#network 10.0.0.0                                       (After run exit command)
R1# copy run start                  (Run copy run start command for save configuration)

Configure RIP R2 Router:-

R2(config)#router rip
R2(config)#network 20.0.0.0
R2(config)#network 30.0.0.0                                      
R2(config)#network 40.0.0.0                           (After run exit command)
R2# copy run start           

Configure RIP R3 Router:-

R3(config)#router rip
R3(config)#network 40.0.0.0
R3(config)#network 50.0.0.0                                       (After run exit command)
R3# copy run start           


Note- After configures all router, run router#show ip route command for see routes.

No comments:
Write comments

Featured Post

NTP and why is important in network

NTP :- NTP stands for Network Time Protocol. Network time synchronization technology was first used in 1979. NTP was designed by David L ...

Contact Form

Name

Email *

Message *

2019 Computer
Powered by Knowitinfo.